Assign a PostbackURL to a specific license key.
Parameter Name |
Data Type |
Sample Input |
Required |
---|---|---|---|
LicenseKey: License key associated with PostBackURL. |
GUID |
f01d89fd-5155-5455-5585-e84ab8de8591 |
TRUE |
PostbackType: Indicates whether PostBackURL is being used for incoming messages, outgoing messages, delivery receipts, or all messages associated with license key. |
String |
All ''Complete list of PostbackType values:
|
TRUE |
Url: URL SMS information is posted to. |
String |
http://www.cdyne.com/postback.aspx |
TRUE |
Parameter Name |
Data Type |
Sample Output |
---|---|---|
ReturnCode: Indicates if an error occurred due to the data in the request. |
String |
No Error ''Complete list of return codes:
|
http://messaging.cdyne.com/Messaging.svc/SetPostbackUrlForLicenseKey?LicenseKey=f01d89fd-5155-5455-5585-e84ab8de8591&PostBackType=All&Url=http://cdyne.com/postbackpage.aspx
require 'net/http'
require 'URI'
puts URI.methods
url = URI.parse("http://messaging.cdyne.com/Messaging.svc/SetPostbackUrlForLicenseKey?LicenseKey=f01d89fd-5155-5455-5585-e84ab8de8591&PostBackType=All&Url=http://cdyne.com/postbackpage.aspx")
res = Net::HTTP.get_response(url)
data = res.body
puts data
gets data
/*http://messaging.cdyne.com/Messaging.svc?wsdl was added as Service Reference and given the name WSDL*/
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using SetPostbackURLForLicenseKey.WSDL;
namespace SetPostbackURLForLicenseKey
{
class Program
{
static void Main(string[] args)
{
MessagingClient client = new MessagingClient("mms2wsHttpBinding");
SMSPostbackReturnCode resp =client.SetPostbackUrlForLicenseKey(new Guid("f01d89fd-5155-5455-5585-e84ab8de8591"), SMSPostbackType.All, "http://cdyne.com/postbackpage.aspx");
Console.WriteLine("Error Setting Postback: " + resp);
Console.ReadLine();
}
}
}
'http://messaging.cdyne.com/Messaging.svc?wsdl was added as Service Reference and given the name WSDL
Imports SetPostbackUrlForLicenseKey.WSDL
Module Module1
Sub Main()
Dim client As WSDL.MessagingClient = New MessagingClient("mms2wsHttpBinding")
Dim resp As Boolean = client.SetPostbackUrlForLicenseKey(New Guid("f01d89fd-5155-5455-5585-e84ab8de8591"), SMSPostbackType.All, "http://cdyne.com/postbackpage.aspx")
Console.Write("Error Setting PostBack: " + Convert.ToString(resp))
Console.ReadLine()
End Sub
End Module
<?php
$url='http://messaging.cdyne.com/Messaging.svc/SetPostbackUrlForLicenseKey?LicenseKey=f01d89fd-5155-5455-5585-e84ab8de8591&PostBackType=All&Url=http://cdyne.com/postbackpage.aspx';
$ch = curl_init();
curl_setopt($ch,CURLOPT_URL,$url);
curl_setopt($ch,CURLOPT_HTTPGET,true);
curl_setopt($ch,CURLOPT_RETURNTRANSFER, true);
curl_setopt($ch, CURLOPT_HTTPHEADER, array('Content-Type: application/json','Accept: application/json'));
//print_r($url);
$response = curl_exec($ch);
curl_close($ch);
print_r($response);
?>
Dim oXMLHTTP
Set oXMLHTTP = CreateObject("Microsoft.XMLHTTP")
Set oDoc = CreateObject("MSXML2.DOMDocument")
Call oXMLHttp.Open("GET", "http://messaging.cdyne.com/Messaging.svc/SetPostbackUrlForLicenseKey?LicenseKey=f01d89fd-5155-5455-5585-e84ab8de8591&PostBackType=All&Url=http://cdyne.com/postbackpage.aspx", False)
Call oXMLHttp.setRequestHeader("Content-Type", "text/xml")
Call oXMLHttp.send
MsgBox oXMLHTTP.responseText
Const ForReading = 1, ForWriting = 2, ForAppending = 8
Const TristateUseDefault = -2, TristateTrue = -1, TristateFalse = 0
Dim fso, MyFile, FileName, TextLine
Set fso = CreateObject("Scripting.FileSystemObject")
FileName = "c:\Users\Desktop\MMS.txt"
Set MyFile = fso.OpenTextFile(FileName, ForWriting, True)
MyFile.WriteLine oXMLHttp.responseText
MyFile.Close
Set MyFile = fso.OpenTextFile(FileName, ForReading)
Do While MyFile.AtEndOfStream <> True
TextLine = MyFile.ReadLine
Loop
MyFile.Close
set request = nothing
import java.io.ByteArrayOutputStream;
import java.io.InputStream;
import java.net.MalformedURLException;
import java.net.URL;
import java.util.Properties;
import javax.xml.transform.OutputKeys;
import javax.xml.transform.Source;
import javax.xml.transform.Transformer;
import javax.xml.transform.TransformerFactory;
import javax.xml.transform.stream.StreamResult;
import javax.xml.transform.stream.StreamSource;
public final class SetPostbackUrlForLicenseKey {
public static void main(String[] args) {
try {
URL url = new URL("http://messaging.cdyne.com/Messaging.svc/SetPostbackUrlForLicenseKey?"
+ "LicenseKey=f01d89fd-5155-5455-5585-e84ab8de8591"
+ "&PostBackType=All"
+ "&Url=http://cdyne.com/postbackpage.aspx");
try {
InputStream in = url.openStream();
StreamSource source = new StreamSource(in);
printResult(source);
} catch (java.io.IOException e) {
}
} catch (MalformedURLException e) {
}
}
private static void printResult(Source source) {
try {
ByteArrayOutputStream bos = new ByteArrayOutputStream();
StreamResult sr = new StreamResult(bos);
Transformer trans = TransformerFactory.newInstance().newTransformer();
Properties oprops = new Properties();
oprops.put(OutputKeys.OMIT_XML_DECLARATION, "yes");
trans.setOutputProperties(oprops);
trans.transform(source, sr);
System.out.println("**** Response ******");
System.out.println(bos.toString());
bos.close();
System.out.println();
} catch (Exception e) {
}
}
}